use strict;
my $str = 'www.vimeo.com/132144170';
my $regex = qr/vimeo.*?([0-9]+$)/ip;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";