package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)vimeo.*?([0-9]+$)`)
var str = `www.vimeo.com/132144170`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}