const regex = /vimeo.*?([0-9]+$)/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('vimeo.*?([0-9]+$)', 'gi')
const str = `www.vimeo.com/132144170`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);