re = /(K((?!\/bc|\/a).)*?)(\d{4})/
str = 'KYan this is /uaaaaaaaa 1987
KYan this is /azzzaaaaaaa 1987
KYan this is /bcaaaaaaa 1987
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end