#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(K((?!\/bc|\/a).)*?)(\d{4})"
Local $sString = "KYan this is /uaaaaaaaa 1987" & @CRLF & _
"KYan this is /azzzaaaaaaa 1987" & @CRLF & _
"KYan this is /bcaaaaaaa 1987" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")