const regex = /(K((?!\/bc|\/a).)*?)(\d{4})/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(K((?!\\\/bc|\\\/a).)*?)(\\d{4})', 'g')
const str = `KYan this is /uaaaaaaaa 1987
KYan this is /azzzaaaaaaa 1987
KYan this is /bcaaaaaaa 1987
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}