use strict;
my $str = '- I\'m not so sure about this tattoo, what if I regret it later?
- You only live once bro.
- Man, all this jumping out of buildings business is taking a toll on my body. Besides, it\'s pretty dangerous!
- Bro, you only live once!';
my $regex = qr/\b(?:you|u) only live once\b/mip;
my $subst = 'YOLO';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";