import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(?:you|u) only live once\\b";
final String string = "- I'm not so sure about this tattoo, what if I regret it later?\n"
+ "- You only live once bro.\n\n"
+ "- Man, all this jumping out of buildings business is taking a toll on my body. Besides, it's pretty dangerous!\n"
+ "- Bro, you only live once!";
final String subst = "YOLO";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}