import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(^bes|\\)$)";
final String string = "Einer der Mönch saß abgesondert auf einem vergoldeten\n"
+ "Stuhl in der Nähe des Gouverneurs. Er war der Mittelpunkt\n"
+ " des Festes, sollte den Ehrenpreis des Jahres für die\n"
+ "beste Arbeit über die uralten Palibücher zuerteilt bekommen.\n"
+ "Seinetwegen saßen all die weisen Buddhaväter dort, mit bes\n"
+ "runden Brillen vor ihren klugen Augen, und warteten auf\n"
+ "His Honour, der den Preis überreichen sollte: ein gebundenes\n"
+ "Exemplar von den Werken der gelehrten Gesellschaft;\n"
+ "die Bücher lagen auf dem Tisch des Gouverneurs aufgestapelt\n"
+ " und warteten ebenso wie wir anderen.";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}