import Foundation
let pattern = #"""
(?ix)
(\w+)\ (semaine|jours)?
|
(demain|ce soir|aujourd'hui|
(next|this)[\ \b](matin|après-midi|soir|Lundi|Mardi|Mercredi|Jeudi|Vendredi|Samedi|Dimanche)
)|(Lundi|Mardi|Mercredi|Jeudi|Vendredi|Samedi|Dimanche)
|
(janvier|février|Mars|Avril|Mai|Juin|Juillet|Août|Septembre|Octobre|Novembre|Décembre)\ (\w+)((\s|\-)?\w*)
"""#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
quelle sera la température dans cinq jours
c'est quoi la température pour aujourd'hui
Comment fera-t-il lundi prochain?
quelle est la température ce soir?
donne-moi la température pour demain matin
quelle sera la température dans 8 semaines
température cet après-midi
température lundi prochain
What is the weather for march 8
What is the weather for march twenty-second
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)