use strict;
my $str = 'quelle sera la température dans cinq jours
c\'est quoi la température pour aujourd\'hui
Comment fera-t-il lundi prochain?
quelle est la température ce soir?
donne-moi la température pour demain matin
quelle sera la température dans 8 semaines
température cet après-midi
température lundi prochain
What is the weather for march 8
What is the weather for march twenty-second';
my $regex = qr/(?ix)
(\w+)\ (semaine|jours)?
|
(demain|ce soir|aujourd'hui|
(next|this)[\ \b](matin|après-midi|soir|Lundi|Mardi|Mercredi|Jeudi|Vendredi|Samedi|Dimanche)
)|(Lundi|Mardi|Mercredi|Jeudi|Vendredi|Samedi|Dimanche)
|
(janvier|février|Mars|Avril|Mai|Juin|Juillet|Août|Septembre|Octobre|Novembre|Décembre)\ (\w+)((\s|\-)?\w*)
/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}