# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = (r"(?ix) \n"
r"(\w+)\ (semaine|jours)?\n"
r"|\n"
r"(demain|ce soir|aujourd'hui|\n"
r"(next|this)[\ \b](matin|après-midi|soir|Lundi|Mardi|Mercredi|Jeudi|Vendredi|Samedi|Dimanche)\n"
r")|(Lundi|Mardi|Mercredi|Jeudi|Vendredi|Samedi|Dimanche)\n"
r"|\n"
r"(janvier|février|Mars|Avril|Mai|Juin|Juillet|Août|Septembre|Octobre|Novembre|Décembre)\ (\w+)((\s|\-)?\w*)\n")
test_str = ("quelle sera la température dans cinq jours\n"
"c'est quoi la température pour aujourd'hui\n"
"Comment fera-t-il lundi prochain?\n"
"quelle est la température ce soir?\n"
"donne-moi la température pour demain matin\n"
"quelle sera la température dans 8 semaines\n"
"température cet après-midi\n"
"température lundi prochain\n"
"What is the weather for march 8\n"
"What is the weather for march twenty-second")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.