// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(\d{4})-(\d{2})-(\d{1,2}) (\d{2}):(\d{2}):(\d{2}).(\d{3})").unwrap();
let string = "2021-08-21 16:21:00.000
2021-08-1 16:21:00.000
2021-08-8 16:21:00.000";
let substitution = "Year: $1 Month: $2 Day: $3 Hour: $4 Minutes: $5 Seconds: $6 Millis: $7";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}