$re = '/(\d{4})-(\d{2})-(\d{1,2}) (\d{2}):(\d{2}):(\d{2}).(\d{3})/m';
$str = '2021-08-21 16:21:00.000
2021-08-1 16:21:00.000
2021-08-8 16:21:00.000';
$subst = "Year: $1 Month: $2 Day: $3 Hour: $4 Minutes: $5 Seconds: $6 Millis: $7";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;