# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\d{4})-(\d{2})-(\d{1,2}) (\d{2}):(\d{2}):(\d{2}).(\d{3})/Year: $1 Month: $2 Day: $3 Hour: $4 Minutes: $5 Seconds: $6 Millis: $7/gm;t' <<< "2021-08-21 16:21:00.000
2021-08-1 16:21:00.000
2021-08-8 16:21:00.000"