re = /Foo\n=+\n((.+)(?:\n-+\n))+/
str = 'Foo
=================
REKJH jdhskd sjdhs sjdhjshd jshdjdh
----------------------
DHKJ DJHDJHDJ DJHDJ ff
-----------------------
REKJH jdhskd sjdhs sjdhjshd jshdjdh
----------------------
DHKJ DJHDJHDJ DJHDJ fff
-----------------------
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end