$re = '/Foo\n=+\n((.+)(?:\n-+\n))+/';
$str = 'Foo
=================
REKJH jdhskd sjdhs sjdhjshd jshdjdh
----------------------
DHKJ DJHDJHDJ DJHDJ ff
-----------------------
REKJH jdhskd sjdhs sjdhjshd jshdjdh
----------------------
DHKJ DJHDJHDJ DJHDJ fff
-----------------------
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);