package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`Foo\n=+\n((.+)(?:\n-+\n))+`)
var str = `Foo
=================
REKJH jdhskd sjdhs sjdhjshd jshdjdh
----------------------
DHKJ DJHDJHDJ DJHDJ ff
-----------------------
REKJH jdhskd sjdhs sjdhjshd jshdjdh
----------------------
DHKJ DJHDJHDJ DJHDJ fff
-----------------------
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}