import Foundation
let pattern = #"\b(\w{6})\b"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
японский программист Юсукэ Эндо (Yusuke Endoh)
японский программист Юсукэ Эндо (遠藤 侑介)
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}