$re = '/\b(\w{6})\b/';
$str = 'японский программист Юсукэ Эндо (Yusuke Endoh)
японский программист Юсукэ Эндо (遠藤 侑介)';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);