re = /\b(\w{6})\b/
str = 'японский программист Юсукэ Эндо (Yusuke Endoh)
японский программист Юсукэ Эндо (遠藤 侑介)'
# Print the match result
str.match(re) do |match|
puts match.to_s
end