// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(Purified)(\s?)(\w+)(\s?)(dust)").unwrap();
let string = "Purified copper ore
Purified copper dust
Tiny copper dust
Copper dust
Small copper dust";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}