#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(Purified)(\s?)(\w+)(\s?)(dust)"
Local $sString = "Purified copper ore" & @CRLF & _
"Purified copper dust" & @CRLF & _
"Tiny copper dust" & @CRLF & _
"Copper dust" & @CRLF & _
"Small copper dust"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")