re = /^list([\*]?):([a-zA-Z]+)\@((\/[\{]?([a-zA-Z0-9]+)[\}?]?)+)/
str = 'list:products@/category/{var1}/products'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end