using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^list([\*]?):([a-zA-Z]+)\@((\/[\{]?([a-zA-Z0-9]+)[\}?]?)+)";
string input = @"list:products@/category/{var1}/products";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}