package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^list([\*]?):([a-zA-Z]+)\@((\/[\{]?([a-zA-Z0-9]+)[\}?]?)+)`)
var str = `list:products@/category/{var1}/products`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}