re = /((?:(?(?=Fig\.|\d+\.\d).+?(?=\s)|[^.!?])+(?=\.))+)/i
str = 'Test 10. Fig. 20. The decimal 20.3 should 20 still be sentence.Ok now. '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end