const regex = /((?:(?(?=Fig\.|\d+\.\d).+?(?=\s)|[^.!?])+(?=\.))+)/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((?:(?(?=Fig\\.|\\d+\\.\\d).+?(?=\\s)|[^.!?])+(?=\\.))+)', 'gi')
const str = `Test 10. Fig. 20. The decimal 20.3 should 20 still be sentence.Ok now. `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}