$re = '/((?:(?(?=Fig\.|\d+\.\d).+?(?=\s)|[^.!?])+(?=\.))+)/i';
$str = 'Test 10. Fig. 20. The decimal 20.3 should 20 still be sentence.Ok now. ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);