import Foundation
let pattern = #"(?:["']?)([a-zA-Z]+(?:-[a-zA-Z]*)+)(?:["']?)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"Lorem ipsum dolor sit amet, consectetur adipisicing elit, sed do "eiusmod-tempor-incididunt" ut labore et dolore magna aliqua. Ut enim ad minim veniam, quis nostrud exercitation ullamco-laboris nisi ut aliquip ex ea commodo consequat. Duis aute irure dolor in reprehenderit in voluptate velit esse cillum dolore eu fugiat nulla pariatur. "Excepteur-sint-occaecat-cupidatat" non proident, sunt-in culpa qui officia deserunt mollit anim id est-laborum."#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)