$re = '/(?:["\']?)([a-zA-Z]+(?:-[a-zA-Z]*)+)(?:["\']?)/';
$str = 'Lorem ipsum dolor sit amet, consectetur adipisicing elit, sed do "eiusmod-tempor-incididunt" ut labore et dolore magna aliqua. Ut enim ad minim veniam, quis nostrud exercitation ullamco-laboris nisi ut aliquip ex ea commodo consequat. Duis aute irure dolor in reprehenderit in voluptate velit esse cillum dolore eu fugiat nulla pariatur. "Excepteur-sint-occaecat-cupidatat" non proident, sunt-in culpa qui officia deserunt mollit anim id est-laborum.';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;