const regex = /(?:["']?)([a-zA-Z]+(?:-[a-zA-Z]*)+)(?:["']?)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:["\']?)([a-zA-Z]+(?:-[a-zA-Z]*)+)(?:["\']?)', 'g')
const str = `Lorem ipsum dolor sit amet, consectetur adipisicing elit, sed do "eiusmod-tempor-incididunt" ut labore et dolore magna aliqua. Ut enim ad minim veniam, quis nostrud exercitation ullamco-laboris nisi ut aliquip ex ea commodo consequat. Duis aute irure dolor in reprehenderit in voluptate velit esse cillum dolore eu fugiat nulla pariatur. "Excepteur-sint-occaecat-cupidatat" non proident, sunt-in culpa qui officia deserunt mollit anim id est-laborum.`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);