import Foundation
let pattern = #"oradata\/OMNIA"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"/dev/u04omnia_lv 100.00 13.33 87% 57 1% /u04/oradata/OMNIA"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}