$re = '/\/(Sites)*\/.*\/Sites\/(.+?)\/(.+?)\/.*/i';
$str = '/Users/demo/Sites/Work/GitHub/ADThemes/Sites/test.com/dev/webroot/css/file.css
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);