using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\/(Sites)*\/.*\/Sites\/(.+?)\/(.+?)\/.*";
string input = @"/Users/demo/Sites/Work/GitHub/ADThemes/Sites/test.com/dev/webroot/css/file.css
";
RegexOptions options = RegexOptions.IgnoreCase;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}