const regex = /\/(Sites)*\/.*\/Sites\/(.+?)\/(.+?)\/.*/i;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\\/(Sites)*\\\/.*\\\/Sites\\\/(.+?)\\\/(.+?)\\\/.*', 'i')
const str = `/Users/demo/Sites/Work/GitHub/ADThemes/Sites/test.com/dev/webroot/css/file.css
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}