$re = '/(([0-9]|[1-9][0-9]|1[0-9][0-9]|2[0-5][0-5])\.){3}([0-9]|[1-9][0-9]|1[0-9][0-9]|2[0-5][0-5])/';
$str = '255.0.0.1
127.0.0.1
127,0,0,1
192.168.178.90
89.50.50.123
0000.2.2.2
2.0000.2.2
2.2.0000.2
2.2.2.0000';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);