package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(([0-9]|[1-9][0-9]|1[0-9][0-9]|2[0-5][0-5])\.){3}([0-9]|[1-9][0-9]|1[0-9][0-9]|2[0-5][0-5])`)
var str = `255.0.0.1
127.0.0.1
127,0,0,1
192.168.178.90
89.50.50.123
0000.2.2.2
2.0000.2.2
2.2.0000.2
2.2.2.0000`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}