import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(([0-9]|[1-9][0-9]|1[0-9][0-9]|2[0-5][0-5])\\.){3}([0-9]|[1-9][0-9]|1[0-9][0-9]|2[0-5][0-5])";
final String string = "255.0.0.1\n"
+ "127.0.0.1\n"
+ "127,0,0,1\n"
+ "192.168.178.90\n"
+ "89.50.50.123\n"
+ "0000.2.2.2\n"
+ "2.0000.2.2\n"
+ "2.2.0000.2\n"
+ "2.2.2.0000";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}