$re = '/^STRBI_(\d{10})_(\d{8})_(STK|SLS)_(.+)\.(\w{3,})$/im';
$str = 'STRBI_0000010006_20171030_STK_Informe de Stock_20171029.csv
STRBI_0000010007_20171030_STK_Informe de Stock_20171029.csv
STRBI_0000010067_20171030_STK_Informe de Stock_20171009.csv
STRBI_0000010087_20171030_SLS_Informe de Ventas Diarias_20171029.csv
STRBI_0000010087_20171030_SLS_Informe de Ventas Semanales_20171022 a 20171029.csv
STRBI_0000010087_20171030_SLS_Informe de Ventas_20171009 a 20171109.csv
STRBI_0000010092_20171030_SLS_Informe de Ventas Diarias_20171029.csv
STRBI_0000010092_20171030_SLS_Informe de Ventas Semanales_20171022 a 20171029.csv
STRBI_0000010092_20171030_SLS_Informe de Ventas_20171009 a 20171109.csv';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);