use strict;
my $str = 'STRBI_0000010006_20171030_STK_Informe de Stock_20171029.csv
STRBI_0000010007_20171030_STK_Informe de Stock_20171029.csv
STRBI_0000010067_20171030_STK_Informe de Stock_20171009.csv
STRBI_0000010087_20171030_SLS_Informe de Ventas Diarias_20171029.csv
STRBI_0000010087_20171030_SLS_Informe de Ventas Semanales_20171022 a 20171029.csv
STRBI_0000010087_20171030_SLS_Informe de Ventas_20171009 a 20171109.csv
STRBI_0000010092_20171030_SLS_Informe de Ventas Diarias_20171029.csv
STRBI_0000010092_20171030_SLS_Informe de Ventas Semanales_20171022 a 20171029.csv
STRBI_0000010092_20171030_SLS_Informe de Ventas_20171009 a 20171109.csv';
my $regex = qr/^STRBI_(\d{10})_(\d{8})_(STK|SLS)_(.+)\.(\w{3,})$/imp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}