#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?im)^STRBI_(\d{10})_(\d{8})_(STK|SLS)_(.+)\.(\w{3,})$"
Local $sString = "STRBI_0000010006_20171030_STK_Informe de Stock_20171029.csv" & @CRLF & _
"STRBI_0000010007_20171030_STK_Informe de Stock_20171029.csv" & @CRLF & _
"STRBI_0000010067_20171030_STK_Informe de Stock_20171009.csv" & @CRLF & _
"STRBI_0000010087_20171030_SLS_Informe de Ventas Diarias_20171029.csv" & @CRLF & _
"STRBI_0000010087_20171030_SLS_Informe de Ventas Semanales_20171022 a 20171029.csv" & @CRLF & _
"STRBI_0000010087_20171030_SLS_Informe de Ventas_20171009 a 20171109.csv" & @CRLF & _
"STRBI_0000010092_20171030_SLS_Informe de Ventas Diarias_20171029.csv" & @CRLF & _
"STRBI_0000010092_20171030_SLS_Informe de Ventas Semanales_20171022 a 20171029.csv" & @CRLF & _
"STRBI_0000010092_20171030_SLS_Informe de Ventas_20171009 a 20171109.csv"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")