re = /(.*\[@name=)(.*)/m
str = '/system.applicationHost/sites/site[@name=\'sub-site.domain.org\' and @id=\'12\']
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end