$re = '/(.*\[@name=)(.*)/m';
$str = '/system.applicationHost/sites/site[@name=\'sub-site.domain.org\' and @id=\'12\']
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);