package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(.*\[@name=)(.*)`)
var str = `/system.applicationHost/sites/site[@name='sub-site.domain.org' and @id='12']
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}