re = /^(?!notword)(?:(?!notword).)*yesword/m
str = 'notword some other junk yesword was not matched
random junk which doesn\'t contain bad stuff and the yesword'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end