const regex = /^(?!notword)(?:(?!notword).)*yesword/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!notword)(?:(?!notword).)*yesword', 'gm')
const str = `notword some other junk yesword was not matched
random junk which doesn't contain bad stuff and the yesword`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}