$re = '/^(?!notword)(?:(?!notword).)*yesword/m';
$str = 'notword some other junk yesword was not matched
random junk which doesn\'t contain bad stuff and the yesword';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);