re = /([\da-zA-Z_-]+)@([\da-zA-Z_-]+).([\da-zA-Z_-]{2,6})?/
str = 'em9ail_name@gmail.com
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end