package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([\da-zA-Z_-]+)@([\da-zA-Z_-]+).([\da-zA-Z_-]{2,6})?`)
var str = `em9ail_name@gmail.com
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}